Not able to accelerate over 86 kms/hr

Sippy

Novice Member
Joined
Jan 6, 2024
Messages
1
Reaction score
0
Points
1
Location
Australia
Driving
CAT Mars Red
We have experienced an issue where our GWM Ora refuses to accelerate above 86 kilometres per hour. This happens when on a motorway or a where it's a multiple lane high speed road. This is scarey because you feel that you don't have control of the car especially if you can't get up to the speed limit of 100 to 110 kms/hr on Australian motorways. A way around it has been to use the cruise control but if it was preset at a faster speed than 86 km/h then the car just accelerates suddenly.

A recent trip to the servicing area last week said it was to do with the Intelligent Overtaking function which we have disabled but it just happened to me again today. Has anyone experienced this issue with their Ora or have any ideas as to what might be causing it? Very reluctant to take the car on the motorway at present.
 
We have experienced an issue where our GWM Ora refuses to accelerate above 86 kilometres per hour. This happens when on a motorway or a where it's a multiple lane high speed road. This is scarey because you feel that you don't have control of the car especially if you can't get up to the speed limit of 100 to 110 kms/hr on Australian motorways. A way around it has been to use the cruise control but if it was preset at a faster speed than 86 km/h then the car just accelerates suddenly.

A recent trip to the servicing area last week said it was to do with the Intelligent Overtaking function which we have disabled but it just happened to me again today. Has anyone experienced this issue with their Ora or have any ideas as to what might be causing it? Very reluctant to take the car on the motorway at present.
Eco mode limits speed...
 
Australian Car, Eco+ mode limits speed, unfortunately the car defaults to that mode frequently (or other drives keep setting it to that mode). Not sure if UK version does that. Software does appear different for Australian cars. We miss out on many things, but our wireless Apple Carplay has worked well from day 1.

I use the physical button to change drive mode, it's pretty easy. Just don't accidently hit the off button for the car.

I agree Eco+ is dangerous and probably should have an option to persistently disable it in the software. It's a bit late when on the onramp to find the car just won't go faster and you need to merge.
 
Australian Car, Eco+ mode limits speed, unfortunately the car defaults to that mode frequently (or other drives keep setting it to that mode). Not sure if UK version does that. Software does appear different for Australian cars. We miss out on many things, but our wireless Apple Carplay has worked well from day 1.

I use the physical button to change drive mode, it's pretty easy. Just don't accidently hit the off button for the car.

I agree Eco+ is dangerous and probably should have an option to persistently disable it in the software. It's a bit late when on the onramp to find the car just won't go faster and you need to merge.
Hi, I'm in the UK and I took mine to a test track and in ECO mode got up to 110mph, but the battery level went done a lot, I thought the sport mode only gave more oomph also mine comes on as NORMAL mode every time I turn it on.
 
Back
Top